Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

ImportError: No module named twisted

See original GitHub issue

I installed the Scrapy by following The installation went perfectly. But when I run

scrapy startproject myproject

I got the following error

Traceback (most recent call last):
  File "/home/karan/coding/bin/scrapy", line 7, in <module>
    from scrapy.cmdline import execute
  File "/home/karan/coding/local/lib/python2.7/site-packages/scrapy/", line 50, in <module>
    from twisted import version as _txv
ImportError: No module named twisted

Issue Analytics

  • State:closed
  • Created 9 years ago
  • Comments:5 (2 by maintainers)

github_iconTop GitHub Comments

SiriusDelycommented, May 13, 2017

following the installation guide, i did pip install Scrapy (with capital S)

but after that, following the tutorial, I tried to create a project using scrapy startproject myproject, and then ended up with similar error with the one in this thread.

so after that, I tried Scrapy startproject myproject (with capital S), and then everything is working fine.

curitacommented, Mar 25, 2015

@karan10 I’ve just commented your proposal in Melange, please check it. Let’s try to keep the discussion in Github, but we should use a proper issue related to your idea to discuss it (this one is a support issue for installing Scrapy, that should be closed because you already fix it).

I recommend you to engage in the discussion of #591, that’s the issue discussing sep-021’s implementation.

Read more comments on GitHub >

github_iconTop Results From Across the Web

ImportError: No module named twisted.internet - Stack Overflow
I figured out why this error was happening. For some reason, using apt-get to install a python package was not installing it right....
Read more >
sslstrip ImportError: No module named twisted.web - Super User
-Trying pip install twisted instead shows this (didn't manage to fix this either): Command 'pip' not found, but there are 18 similar ones....
Read more >
twisted for kivy-ios, ImportError: No module named twisted
Hi,. Testing "twisted" with kivy on Android, it works. When testing it on iOS, it gets an ImportError, "ImportError: No module named twisted."....
Read more >
ImportError: No module named twisted.web
This is pure python error. It means, you haven't installed specified dependency (twisted.web) yet. Guess, you should install required python ...
Read more >
How to install Python-twisted - Raspberry Pi Forums
Done E: Unable to locate package python-twisted pi@rpitest64:~ ... Factory ImportError: No module named twisted.internet.protocol ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found