Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Cannot access webstite URL, 503 error

See original GitHub issue

Describe the bug

When I start using wp local docker cca 3 months ago, everything was fine except SSL (I didn’t care about SSL so I just commented 443 port). But recently I added a new website and cleared cache and since then I’m having this problem. But anyway I don’t think the problem is with my setup. Because now I reinstall OS and I’m having exactly the same issue again. All services are running and logs seem to be OK

Cannot access a website. Without HTTP version http://test-dev-wp.test I’m getting: (screenshot below)

503 Service Temporarily Unavailable

With HTTPS https://test-dev-wp.test : (screenshot below)

Secure Connection Failed

An error occurred during a connection to test-dev-wp.test. PR_END_OF_FILE_ERROR

Steps to Reproduce

  1. Install fresh 10updocker with npm install -g wp-local-docker
  2. Create environment with 10updocker create command
  3. Follow instructions and create single wordpres site fx test-dev-wp.test
  4. Wait till finish and try to access website
  5. Logs: nginx container 10up/nginx-proxy wp-php-fpm-dev-7.4

Expected behavior

Be able at least access not secure (HTTP) version.


docker services SSl-error 503error

Environment information

  • Device: ThinkPad W520
  • OS: Arch Linux, Kernel: 5.10.28-1-lts
  • Browser and version: Firefox 87.0, Chromium 89.0.4389.114
  • WordPress version: 5.7

Additional context

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:6

github_iconTop GitHub Comments

azatecascommented, May 11, 2021

I was setting up 10updocker on Fedora 34 and ran across the same issue. I tried debugging it for hours and reinstalled it a bunch of things. However i ended up trying the #188 10updocker on m1 solution and it worked. I edited the ~/.wplocaldocker/global/docker-compose.yml file and change the gateway from 10up/nginx-proxy to 10up/nginx-proxy:multiarch and mysql:5 to image: mariadb and it started working. I honestly have no idea why it worked but give it a shot

tylercherpakcommented, Dec 14, 2021

Going to close this one since I haven’t heard back but if you are still having issues feel free to comment and I will open it back up! Thanks all!

Read more comments on GitHub >

github_iconTop Results From Across the Web

What is HTTP error 503 and how do you fix it? - IT PRO
An HTTP error 503 is found when your browser encounters a website that is unable to establish a connection with its server. Many...
Read more >
How to Fix the HTTP Error 503 Service Unavailable - Kinsta
The 503 error in WordPress signifies that your website can't be reached at the present moment because the server in question is unavailable....
Read more >
How to Fix 503 Service Unavailable Error: 7 Steps That Work
In this tutorial, learn what the 503 service unavailable error means and 7 proven methods to fix it to get your website back...
Read more >
What Does HTTP Error 503 (Service Unavailable) Mean ...
A 503 Service Unavailable Error is an HTTP response status code that indicates your web server operates properly, but it can't handle a...
Read more >
503 Service Unavailable Error Message: What It Is and How to ...
The 503 Service Unavailable error is an HTTP status code that means a website's server is not available right now. Most of the...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found