Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Deprecation error when creating new site

See original GitHub issue
Error : time="2021-06-18T00:47:56+02:00" level=warning msg="network wplocaldocker: is deprecated in favor of"
time="2021-06-18T00:47:56+02:00" level=warning msg="volume wplocaldockerCache: is deprecated in favor of"

I suppose things should be specified like this:

    external: true
    name: <cool-volume-name>

Environment information

  • Device: Macbook Air M1
  • OS: Big Sur 11.4
  • Docker Desktop version: 3.4.0 (65384)

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:13 (3 by maintainers)

github_iconTop GitHub Comments

tcmuldercommented, Dec 27, 2021

I’m still having this issue. I’ve done @dustinrue’s recommendation and still see the error:

WARN[0000] network wplocaldocker: is deprecated in favor of
WARN[0000] volume wplocaldockerCache: is deprecated in favor of

every time wp cli runs any of its commands. This is on v3.0.0 installing a new site with 10updocker create, no plugins installed using the twentytwentyone theme.

I was getting this before upgrading to 3.0.0. I’m now also getting a 3rd error every time after the upgrade:

PHP Warning:  PHP Startup: Unable to load dynamic library '' (tried: /usr/lib/php/20190902/ (/usr/lib/php/20190902/ cannot open shared object file: No such file or directory), /usr/lib/php/20190902/ (/usr/lib/php/20190902/ cannot open shared object file: No such file or directory)) in Unknown on line 0

Everything appears to work… just annoying having to skip past all these warnings to see if everything succeeded. Note this happens after installation as well, e.g. if I run wp option get home the same three warnings appear before my URL gets output to the console.

Environment information

  • Device: Macbook Pro M1
  • OS: Monterey 12.0.1
  • Docker Desktop 4.3.2 (72729)
dustinruecommented, Aug 4, 2021

Ok, looks like it is the global gateway image. You can install our test version using npm install -g wp-local-docker@release_2_8_2. Once installed, you need to run 10updocker configure and select all default options until you are asked Do you want to reset your global services configuration? This will reset any customizations you have made. Select ‘y’ (yes) for this question. This will replace your global configuration with an updated one that spec’s some new containers. You may still get the deprecated warning but you should be able to create sites on M1.

Read more comments on GitHub >

github_iconTop Results From Across the Web

What does this deprecation warning mean, and how to fix it?
I get a deprecation warning: DEPRECATION: A future pip version will change local packages to be built in-place without first copying to a ......
Read more >
Deprecation Errors - How to Fix? - Craft CMS Stack Exchange
We are in development of our new site in Craft 3 and we are getting some deprecation errors. This is keeping us from...
Read more >
Deprecation warnings and errors when trying to install new ...
Insane amount of deprecation warnings and errors by trying to install a new gatsby project. Installed project via global installed official ...
Read more >
Fix Your Craft CMS Deprecation Errors - CraftQuest
When the Craft CMS team deprecated a template function, for example, they kindly log a deprecation warning to alert you, and then call...
Read more >
Sorry, something went wrong error on a Site Page with a ...
To resolve this issue: Create a page in the pages library and add the web part there, instead of creating the page in...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found