question-mark

Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Installing the client packages fails on Linux Mint 20

See original GitHub issue

Issue Description

System Information OS: Linux Mint 20 Python: 3.8.5 GCC: 9.3.0

Describe the bug I am following the quick start guide to test OpenCue before I deploy it. I followed all the steps successfully and managed to build the docker container and it is running with the following output:

cuebot_1 | WARNING: An illegal reflective access operation has occurred cuebot_1 | WARNING: Illegal reflective access by com.google.protobuf.UnsafeUtil (jar:file:/opt/opencue/cuebot-0.4.55-all.jar!/BOOT-INF/lib/protobuf-java-3.4.0.jar!/) to field java.nio.Buffer.address cuebot_1 | WARNING: Please consider reporting this to the maintainers of com.google.protobuf.UnsafeUtil cuebot_1 | WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations cuebot_1 | WARNING: All illegal access operations will be denied in a future release rqd_1 | WARNING:root:RQD Started cuebot_1 | 2020-10-18 14:55:42,678 WARN pool-1-thread-1 com.imageworks.spcue.dispatcher.HostReportHandler - Unable to find host 172.18.0.5,org.springframework.dao.EmptyResultDataAccessException: Failed to find host 172.18.0.5 , creating host.

However, installing the client packages fails when I run the sandbox/install-client-archives.sh script. The entire output of the script is in this pastebin. I don’t want to paste it here because it is more than 4000 lines.

The culprit, as far as I can tell, seems to be grpcio. When trying to build it, I get this error:

Building wheel for grpcio (setup.py) … error ERROR: Command errored out with exit status 1: command: /home/abdelrahman/Sources/OpenCue/venv/bin/python -u -c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/tmp/pip-install-89hkuygl/grpcio/setup.py’“'”‘; file=’“'”‘/tmp/pip-install-89hkuygl/grpcio/setup.py’“'”‘;f=getattr(tokenize, ‘"’“‘open’”’“‘, open)(file);code=f.read().replace(’”‘"’\r\n’“'”‘, ‘"’"’\n’“'”‘);f.close();exec(compile(code, file, ‘"’“‘exec’”’"‘))’ bdist_wheel -d /tmp/pip-wheel-pqhekyoa cwd: /tmp/pip-install-89hkuygl/grpcio/

The python tracebacks all show distutils errors, sometimes a DistutilsExecError, sometimes a CompileError, but they all have the following message:

command ‘x86_64-linux-gnu-gcc’ failed with exit status 1

When I looked this error online, all the suggestions seemed to revolve around installing the python-dev or build-essential packages, but I have these two installed on my system already, so I am not sure what is causing the issue.

To Reproduce Steps to reproduce the behavior: Just follow the steps from the quick start guide up to Installing the OpenCue client packages, specifically where you run this command sandbox/install-client-archives.sh

Version Number I tried three different versions: 0.4.55 0.4.14 0.2.65 (from the quick start guide)

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:10

github_iconTop GitHub Comments

1reaction
amsaid1989commented, Jun 30, 2022

Glad it worked for you. Looks like the documentation definitely needs to be clear in this regard. I haven’t looked at it for a while now, but I may check it later and see if I can submit a pull request to update it.

For now, I will close this issue, since it looks like it might be irrelevant for the current version of OpenCue.

1reaction
johhnrycommented, Jun 30, 2022

@amsaid1989 Thanks for the feedback!

I think that the documentation is not up to date with the matching version of the prebuilt OpenCue images of Cuebot and RQD on Docker Hub used in the sandbox environment.

The exception syntax error line is from the 0.2.65 tag: https://github.com/AcademySoftwareFoundation/OpenCue/blob/0.2.65/cuesubmit/cuesubmit/ui/Submit.py

I tried:

export VERSION=0.15.22
sandbox/install-client-archives.sh

and it worked! Maybe the documentation should be more clear about which versions of cueadmin/gui/submit match the docker images…

Read more comments on GitHub >

github_iconTop Results From Across the Web

[SOLVED] Failed to load the package list - Linux Mint Forums
Re: Failed to load the package list. kshitij@kshitijs-linux:~$ sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 4773BD5E130D1D45 [ ...
Read more >
Fresh Mint 20.2 Install - Impossible to install any software
Hi everyone, I'm a beginner to Linux but this time, when I did an install of the last Mint package on my new...
Read more >
Mint install fails to install packages [solved] - Linux Mint Forums
Clicking the install button in Mint Install does nothing. Running from the command line resulted in this error: Code: Select all. Traceback ( ......
Read more >
<Solved>Unable to install packages<solved>
The Linux Mint 20.1 installation asked me if I wanted to configure that and I think I successfully enrolled it in MOK or...
Read more >
[SOLVED] Unable to install hplip 3.20.6 in Linux mint 20 ...
Press <enter> to accept the default. error: linuxmint-20 version is not supported, so all dependencies may not be installed.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Dev.to Post

No results found

github_iconTop Related Hashnode Post

No results found