Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Can't open database

See original GitHub issue

Issue Description

  • version: 0.8.0
  • os: Debian 10

When I try to open sqlite file I get

Unable to find a valid SQLite command. Fallback binary is not valid.


[2:37:39 AM][vscode-sqlite][ERROR] Unable to find a valid SQLite command. Fallback binary is not valid.

I saw a very similar closed issue that occurred in CentOS. It’s said that it is fixed by some ad-hoc solution specific for CentOS. I suspect the same reason and it can be fixed in the same way but this time for Debian 10?

The issue is referenced below.

Should be fixed in version 0.7.1 There were a couple of problems: It failed to recognize if the SQLite binaries were not supported (it’s needed at least version 3.9), and on CentOS the binaries provided throw an error when started, but work fine after that. I fixed the first problem and added a workaround for the second. If there are other errors feel free to reopen this issue.

_Originally posted by @AlexCovizzi in

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:27 (4 by maintainers)

github_iconTop GitHub Comments

ingun37commented, Jun 5, 2020

It exited right away. After I read the error message I tried installing sqlite3 using apt and it worked. I’m happy with the solution so I would close the issue.

douglasmatosdevcommented, Jul 8, 2020

@ingun37 @vaMuchenje @guilhermebellotti @AlexCovizzi @W3ND31 @SrAmaral @matias2018 @ricardovasconcelos @joao-gabriel-gois

I decided by doing: sudo apt-get install sqlite3 libsqlite3-dev

Then, in settings.json sets the path to the sqlite3 binary: "sqlite.sqlite3": "/usr/bin/sqlite3"

Read more comments on GitHub >

github_iconTop Results From Across the Web

Cannot open database “. It may not be a database that your
An Access 2007 database that we recently constructed started giving the following error message when we try to enter attachments, "Cannot open ......
Read more >
[SOLVED] Access Cannot Open a Database Created With a ...
If you cannot convert the Access database .mdb file, it means that the file is corrupt. You can try to repair the database...
Read more >
5 Fixes To Resolve Access Error 3049 - Cannot Open Database
The error itself reflects that the Access database compress operations are stopped due to some unknown reasons and you are left with inaccessible...
Read more >
How to Fix "Cannot open database. (Error 3049)" in MS Access
You may come across a message “Cannot open database. (Error 3049)” while working on your Access database. You were probably creating new ...
Read more >
Error: Cannot open database requested by the login. The ...
The first cause of the error may be that the machine name of the SQL Server needs to be specified so that the...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found