Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Failed to open database

See original GitHub issue

I got this error - that was fixed here - in the latest version.

I resolved that downgrading the version to 0.7.1, but the problem returned.


Failed to open database: Database failed to open: SQLite process failed to start: The argument 'file' cannot be empty. Received ''

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:19 (1 by maintainers)

github_iconTop GitHub Comments

Henriquepb22commented, Aug 29, 2021

I got the same error here, and when browsing to find a fix i found this issue, so the problem is that some linux (ubuntu 20.04 here) cant run sqlite3 explorer without sqlite3 packages installed, so you need to install it, run:

 sudo apt install sqlite

and i think it will fix it (worked for me)

Edit: check for fix without installing any package

W3ND31commented, Jun 6, 2020

Guys, u don’t need this. If u enabled “sqlite.logLevel”:“DEBUG” on VsCode JSON Settings, look for the file like “/home/wendel/.vscode/extensions/alexcvzz.vscode-sqlite-0.8.2/bin/sqlite-v3.26.0-linux-x64”

Go to terminal and type “chmod +x /home/wendel/.vscode/extensions/alexcvzz.vscode-sqlite-0.8.2/bin/sqlite-v3.26.0-linux-x64”

And the issue is resolved without installing anything else.

I think that this will happen only on unix SO’s.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Getting "Failed to open database" error when copying a sqlite ...
I had to modify checkDataBase() to private boolean checkDataBase() { File databasePath = mContext.getDatabasePath(DB_NAME); return ...
Read more >
How to Fix SQLite Unable to Open Database File Issue?
If SQLite is unable to open the database file, this means that the SQLite database you are trying to open is corrupted.
Read more >
Unable to open an Access database on a server - Office
When you try to open a database that is located on a server, you may receive the following error message: Couldn't use <filename>;...
Read more >
Nightly task emails indicate it was unable to open the database
The error that occurs is structured by naming the daily or nightly task name, followed by the ": Failed to Open Database.
Read more >
Failure to open database - Audacity Forum
Today I tried to open some similar flac files and got the "Failure to open database" error message. I tried opening the flac...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found