Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Some issues I noticed with latest commits

See original GitHub issue

Issue Description

So glad to see @Prefinem working on this again =]

  1. I pulled the latest commit hoping it would fix torrent updates in loader.js but it seems the same behaviour to me. I don’t see seed/leech being updated. Nothing shows up in loader-out.log, or loader.error.log with debug = true in index.js. When I run scraper.js I see in log:

Total Torrents: 785004 Torrents without Tracker: 781921 Torrents not in Search: 361

  1. Another issue I found was that I kept noticing 0 byte files being scraped, or at least I thought they were 0byte! When I checked mysql I found they had a proper length field BUT they had a huge files field which was always truncated abruptly due to max length on TEXT type field in mysql. You can maybe see what I mean here:

I did this to test (ALTER TABLE torrents MODIFY `files` MEDIUMTEXT;) and it seems no more broken file lists but this opens us up to 16mb max record sizes on this field. Might be worth it to truncate these instead in parser.js but I’m not sure the best approach 😕

  1. The last issue I noticed is I still cannot seem to filter out the invalid character � from scrapes, I’ve tried 0xFFFD, � - and a few others…but I’ll keep trying. I haven’t tested but I think this should work on all unexpected characters: dataStr.replace(/[\u{0080}-\u{FFFF}]/gu,"");

Issue Analytics

  • State:open
  • Created 4 years ago
  • Comments:33 (10 by maintainers)

github_iconTop GitHub Comments

ghostcommented, Feb 8, 2019
Showing rows 0 - 751 (752 total, Query took 3.2976 seconds.)
select * from `torrents` where `searchUpdate` = false limit 1000


Showing rows 0 - 419 (420 total, Query took 0.8087 seconds.)
select infohash from `torrents` where `searchUpdate` = false limit 1000
ghostcommented, Feb 8, 2019

it appears overnight its not even querying the database to update trackers… and i havent changed strange on hetzner server and digital ocean.

update… seems opensurfer not working same for milez. would it be possible to add some type of fallback or timeout. so if opensurf not responding use a fallback tracker? @Prefinem

Read more comments on GitHub >

github_iconTop Results From Across the Web

Sometimes recent commits that exist on the remote repository ...
Issue Summary. Sometimes recent commits that exist on the remote repository are not visible in the website, in the 'Commits' page of the...
Read more >
Git happens! 6 Common Git mistakes and how to fix them
Another common Git pitfall is committing too early. You missed a file, forgot to save it, or need to make a minor change...
Read more >
git commit problems
Short answer: git push -u origin master. Longer answer: You're most likely trying to push commits to a branch that wasn't created yet...
Read more >
checkout@v2 not getting recent commits · Issue #439
I don't get any error, the checkout succeeds but it doesn't get the latest commits. Seems to use some sort of cache.
Read more >
Don't git revert that last commit, git reset instead | TheServerSide
First, when you git reset the last commit, the ID of the bad commit isn't pushed to any remote repository. With a reset,...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found