Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

AppTrackingTransparency pop-up never shows up

See original GitHub issue

After following the readme provided, we get the following error log on trying to invoke the iOS ATT confirmation pop-up:

[DEBUG] AppsFlyer: [SKAd] Timeout exceded. sk_exp = 0.000000

This c# code gets executed on Unity’s side: AppsFlyer.initSDK(IOSAppsFlyerKkey, IOSAppId, this); if (new Version(Device.systemVersion) .CompareTo(new Version("14.0")) >= 0) { AppsFlyeriOS.waitForAdvertisingIdentifierWithTimeoutInterval(60); } AppsFlyer.startSDK();

This is the modified “didFinishLaunching” snippet: `

  • (void)didFinishLaunching:(NSNotification*)notification { if (@available(iOS 14, *)) { [ATTrackingManager requestTrackingAuthorizationWithCompletionHandler:^(ATTrackingManagerAuthorizationStatus status){ }]; } NSLog(@“got didFinishLaunching = %@”,notification.userInfo); if (notification.userInfo[@“url”]) { [self onOpenURL:notification]; } } `

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:10 (1 by maintainers)

github_iconTop GitHub Comments

myrikcommented, Aug 26, 2020

I ran into something like this yesterday and it seems to be because AppsFlyerAppController isn’t actually being used (I don’t see any of the NSLogs in my console).

We also have Swrve integrated in our app and adding the call to requestTrackingAuthorizationWithCompletionHandler in SwrveUnityAppControllerSub fixed it for us. I haven’t dug too deep into this yet, but perhaps another class is overriding UnityAppController for you?

Goncharuk-Nikitacommented, Jun 15, 2022

Hello, I just copy some unanswered questions on this topic.

  1. Is it correct that AppsFlyerSdk will not call requestTrackingAuthorizationWithCompletionHandler to ask for permissions, and it is a developer’s responsibility to make this call explicitly?

  2. If yes, Should I call it before or after initSDK or startSDK? Should I wait for a permission callback and then startSDK? (In AppsFlyer Unity SDK)

Read more comments on GitHub >

github_iconTop Results From Across the Web

App Tracking Transparency Dialog does not appear on iOS
The popup is being presented on the first app launch on iOS15. In my case, Settings -> Privacy & Security -> Tracking ->...
Read more >
App Tracking Transparency Alert not Showing and status . ...
which, to my understanding, means the function is called and the request goes through, but the alert is never displayed and it assumes...
Read more >
Why you might not be seeing iOS 14.5's new privacy pop-ups
In iOS 14.5, all apps must ask for permission before they can monitor you. Unless you approve, they can't show targeted ads based...
Read more >
ATT prompt not showing on iOS 15? : r/iOSProgramming
Your app uses the AppTrackingTransparency framework, but we are unable to locate the App Tracking Transparency permission request.
Read more >
App Tracking Transparency framework on Unity
The package is already in the package manager. I just imported it and with a couple of lines of code it's showing the...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found