Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Cannot read property appVersion of undefined - iOS

See original GitHub issue

It works perfect in Android version, but in iOS version, I’m receiving this error.

I tried to use version 0.3.0 (Currently using 0.2.0) but I got some errors trying to install via yarn, it throws an error about access in some git files.

I already try react-native link but nothing happens.

Any clue?

screen shot 2017-11-01 at 17 15 34

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Reactions:3
  • Comments:5

github_iconTop GitHub Comments

hanssonfredrikcommented, May 5, 2018

I installed version 0.3.3 and got this error. Works fine on Android.


all above returns undefined on iOS, but correct values on Android. Do I have to manually link the library or just go with the pod file installation? I have only tried this in the emulator and not on a real device.

morksinaanabcommented, Nov 6, 2017

I had the same. Fixed now: Did you make sure

  1. you used --save so it’s in your package.json
  2. when you run react-native link you see in the output it is linked
  3. after you’ve run react native link made sure you build the app again (i.e. react-native run-ios) instead of just (hot)reloading? -> and to be sure clean the project in xcode before building again
Read more comments on GitHub >

github_iconTop Results From Across the Web

Cannot read property 'installCoreFunctions' of undefined
I am trying to integrate Reanimated 2.0 in iOS React Native swift project and getting the below error. Android App is working fine...
Read more >
Error: Cannot read property 'push' of undefined React Native
I ran into this issue today, the reason is that you need to call the screen where you're using this.props.navigator.push with the NavigatorIOS...
Read more >
react-native-device-info - npm
Linking in native modules is a frequent source of trouble for new react-native developers, resulting in errors like "RNDeviceInfo is null" ...
Read more >
Troubleshooting - React Navigation
Now rebuild the app and test on your device or simulator. I'm getting an error "TypeError: Cannot read property 'bind' of undefined" or...
Read more >
cannot read properties of undefined navigate -
Cannot read property 'navigate' of Undefined in React Navigation ... Render the StackNavigator in your index.ios.js and move the button to the Login ......
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found