Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

"npm start" is not working

See original GitHub issue

while I am trying to run the project I am getting bellow error.

Please note : I have not done any changes to project and I am running code from master branch . I tried with yarn also . node: 12.19.0v


SyntaxError: D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\watchpack\lib\chokidar.js: 'return' outside of function (4:1)

  2 | try {
  3 |   module.exports = require("chokidar");
> 4 |   return;
    |   ^
  5 | } catch(e) {
  6 |   v3Err = e;
  7 | }
    at Object._raise (D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\@babel\parser\src\parser\error.js:60:45)
    at Object.raiseWithData (D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\@babel\parser\src\parser\error.js:55:17)
    at Object.raise (D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\@babel\parser\src\parser\error.js:39:17)
    at Object.parseReturnStatement (D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\@babel\parser\src\parser\statement.js:563:12)
    at Object.parseStatementContent (D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\@babel\parser\src\parser\statement.js:197:21)
    at Object.parseStatement (D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\@babel\parser\src\parser\statement.js:151:17)
    at Object.parseBlockOrModuleBlockBody (D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\@babel\parser\src\parser\statement.js:871:25)
    at Object.parseBlockBody (D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\@babel\parser\src\parser\statement.js:841:10)
    at Object.parseBlock (D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\@babel\parser\src\parser\statement.js:811:10)
    at Object.parseTryStatement (D:\ResumeBuilder\V03\avinash-resume-pwa\node_modules\@babel\parser\src\parser\statement.js:653:23) {
  loc: Position { line: 4, column: 1 },
  pos: 57,

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Reactions:5
  • Comments:10 (2 by maintainers)

github_iconTop GitHub Comments

sunilhari9commented, Jun 17, 2021

Same for me any solution for this?

jeffwilcoxcommented, Mar 13, 2021

Hopefully this pull request is accepted at some point in watchpack

Read more comments on GitHub >

github_iconTop Results From Across the Web

How to fix npm start command not working - Nathan Sebhastian
How to fix npm start command not working · Check if you have a package.json file in your project · Check if you...
Read more >
NPM Start not starting local server - node.js - Stack Overflow
5 Answers 5 · it gives me this error: Cannot find module '/Users/dheeraj/Project/reactWeb/webpack-dev-server' · Drop the ./ from the path. · @ ...
Read more >
npm ERR! Missing script: "start" [Solved] | bobbyhadz
To solve the npm ERR! Missing script: "start" error, make sure to add a start command to the scripts object in your package.json...
Read more >
npm start not working, tried many solves :| #1328 - GitHub
derweili commented on Jan 17, 2019 · Delete the node_modules folder. · Open the package.json · Search for "gulp": "gulpjs/gulp#4.0", and replace it ......
Read more >
How to fix npm start command not working -
How to fix npm start command not working · Creating a package.json file · Creating a start script · Disabling ignore-scripts · Conclusion....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found