Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Not working build

See original GitHub issue

Hello, I have been developing my new app with pawjs for several weeks so far and now the deploy time has came. However, when I tried to run build with following command: npm run build && node dist/server.js (on new machine with clean deps install) it fails on following error: Error: Cannot find module “…/app/components/Error/404”

Interestingly, I tried to build on another machine (old deps installed weeks ago) and it gives me another error: TypeError: n is not a function. But main point is, it fails on node dist/server.js command… what can I do? Or how can I bypass it at least temporary? Do you need any other info from me in order to debug it more properly?

Thank you very much advance.

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Comments:6 (2 by maintainers)

github_iconTop GitHub Comments

jsifaldacommented, Mar 23, 2018

When I disabled the uglification, I managed to found out that TypeError: n is not a function is actually TypeError: require is not a function… in one of the libraries I use. After long time researching, I managed to fix with this "global.GENTLY": false adding it into uglifyJS configuration… (in DefinePlugin)

tirthbodawalacommented, Mar 22, 2018

@jsifalda storage option is provided out of the box via pawjs you can find it in direct route components via this.props.localStorage ==> this localStorage is actually Cookie Storage.

To stop uglification for servers there is no such option in current version (we are adding that in upcoming stable version of pawjs) but you can directly go to node_modules/pawjs/src/webpack/config/prod.server.babel.js and comment the uglify plugin totally temporarily.

Will provide a path soon.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Build is not working · Issue #3223 - GitHub
It is the problem with all the newly-created ReadTheDocs-projects. If the new git-project is loaded to old ReadTheDocs project, then it works ...
Read more >
Build not build/rebuild/clean doesn't starting
Visual Studio 2015 appears to work correctly, until I attempt to build, rebuild, or clean a project or solution. Then the build seems...
Read more >
Common Build Problems - Travis CI Docs
Common Build Problems · My tests broke but were working yesterday · My build script is killed without any error · My build...
Read more >
Troubleshooting build errors and crashes - Expo Documentation
A reference for troubleshooting build errors and crashes when using EAS Build.
Read more >
Build troubleshooting tips - Netlify Docs
This article provides troubleshooting tips for failing builds in Netlify's build service. In case your build fails on Netlify, first make sure it...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found