Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Emulator won't show 'Robot Code Connected'

See original GitHub issue

Describe the bug After installing the latest version of Autodesk Inventor Professional 2021 and Synthesis, my code will not run. The status of each process in the driver station eventually turns green except for Robot Code Connected. I believe this is because the emulator is running an outdated version of the WPI libraries, I have the 2020.1.2 version. The driver station log file says that the emulator has the 2019.4.1 version. I have already tried changing up the code and just setting a certain power to motors of the code but none will work. I am using java (JDK 11).

To Reproduce Steps to reproduce the behavior:

0.1. Download, extract it and build it using gradle (e.g. gradle build).

  1. Open Synthesis (
  2. Select a robot
  3. Go to Emulation
  4. Select “Start Emulator” Wait for the ‘Emulator Connected’ green status light located on the Driver Station.
  5. Select “Select Code” and select the .jar file (located at SimpleChassis/build/libs/SimpleChassis.jar)Wait for the 'Robot Code Uploaded", “Robot Code Running”, and “Robot Code Connected” green status lights located on the Driver Station. Step 5 is where the bug happens, “Robot Code Connected” never changes to a green status light.
  6. Click on “Use emulation”.

Expected behavior it should show all 4 green status lights on the driver station.


  • Driver Station log image
  • Synthesis screenshot

Desktop (please complete the following information):

  • OS: Windows 10 Home
  • Version 1909
  • Synthesis version


Issue Analytics

  • State:closed
  • Created 3 years ago
  • Reactions:1
  • Comments:10 (4 by maintainers)

github_iconTop GitHub Comments

Jesmuccommented, Dec 27, 2020

@copernicium that also works for java code (generated with 2019 WPILib), thanks!

KiraCorbettcommented, Dec 19, 2020

@TrevCan You can check our Synthesis 4.2 tutorials on our YouTube channel here or our Google Codelabs tutorial for setup here. For Fusion, please see these tutorials here.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Unable to connect to Robot Simulator - android studio
When I start the emulator, the Starting Emulator screen stays at 34%, and the Robot Viewer does not show up. I've tried connecting...
Read more >
[SOLVED] Cannot connect to the Emulator
I am trying to debug my application but everytime I try to debug on Emulator I have the Following error: Can't run application....
Read more >
Unable to get Synthesis Code Emulator working in Java
Our problem is that when we upload the robot code, the connection light does not show up (as seen in the screenshot below)....
Read more >
FRC Emulation: Running your C++ or Java Robot Code in ...
Click on the Start Emulator button on the left-hand side of the Emulation toolbar. This will automatically open the Synthesis Driver Station where...
Read more >
Test and debug bots using the Bot Framework Emulator
Learn how to inspect, test, and debug bots using the Bot Framework Emulator desktop application.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found