Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

failed building service 'web'

See original GitHub issue

This issue is for a: (mark with an x)

- [x] bug report -> please search issues before submitting
- [ ] feature request
- [ ] documentation issue or request
- [ ] regression (a behavior that used to work and stopped in a new release)

Minimal steps to reproduce

  1. Open repo in Codespaces
  2. open bash terminal
  3. execute azd auth login
  4. execute azd up

Any log messages given by the failure


Expected/desired behavior

Deploy the solution into specified azure subscription

OS and Version?

Opened the repo with provided Codespaces

Mention any other details that might be useful

Issue Analytics

  • State:open
  • Created 4 months ago
  • Comments:8

github_iconTop GitHub Comments

lynnaloocommented, Jun 22, 2023
erezbatish-mscommented, Jun 7, 2023

Running Codespaces from VS Code did the trick, and I was able to run the workflow successfully. Thank you Luis.

From: Erez Batish @.> Date: Wednesday, 7 June 2023 at 17:08 To: Azure-Samples/azure-search-openai-demo-csharp @.>, Azure-Samples/azure-search-openai-demo-csharp @.> Cc: Mention @.> Subject: Re: [Azure-Samples/azure-search-openai-demo-csharp] failed building service ‘web’ (Issue #106) The issue is that I’m using corp subscription which is not allowing to be authorized from a non-managed device, so I can’t run It in Codespaces. I can try to run Codespaces from VS Code and see if it will allow me to auth to my subscription.

From: Luis Quintanilla @.> Date: Wednesday, 7 June 2023 at 17:05 To: Azure-Samples/azure-search-openai-demo-csharp @.> Cc: Erez Batish @.>, Mention @.> Subject: Re: [Azure-Samples/azure-search-openai-demo-csharp] failed building service ‘web’ (Issue #106)

@erezbatish-ms thanks for that info. Looks like your issue is different from the original issue. Could you try running the sample in Codespaces? I don’t have a Mac so I can’t repro on that environment.

— Reply to this email directly, view it on GitHub, or unsubscribe You are receiving this because you were mentioned.Message ID: @.***>

Read more comments on GitHub >

github_iconTop Results From Across the Web

docker-compose: Service 'web' failed to build
I'm trying to install apach2, libapache2-mod-wsgi-py3 and openssl in the container. I've removed some packages and fix typos in Dockerfile but ...
Read more >
Service 'web' failed to build - 🚧 Installation
Hello, I'm trying to get a fresh installation of nextcloud working with docker and Portainer. My choice is to install it using the...
Read more >
ERROR: Service 'web' failed to build: when I run make ...
On an Ubuntu Xenial AWS machine, I downloaded and installed the docker engine, and under my py3 virtualenv I installed docker composer via...
Read more >
Service 'web' failed to build: - Docker Desktop for Windows
Hello everybody, I'm new on docker and I'm working on a project that started before I get in. So my problem is with...
Read more >
[Solved]-docker-compose: Service 'web' failed to build-docker
The \ is a continuation and the next thing it sees is RUN so is treating that like a package (which it can't...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found