Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error writing output files

See original GitHub issue


I tried to run CellBender with the following command: cellbender remove-background \ --input raw_feature_bc_matrix \ --output pool_38-2.h5 \ --expected-cells 5000 \ --total-droplets-included 15000 \ --epochs 300

However, I got the following error in the log file: Encountered an error writing output to file pool_38-2.h5. Output may be incomplete. Encountered an error writing output to file pool_38-2_filtered.h5. Output may be incomplete.

No .h5 output is being produced, only log file, pdf and csv file with cell barcodes, which is not empty.

I have attached log file and output pdf here. pool_38-2.log pool_38-2.pdf


Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:9 (5 by maintainers)

github_iconTop GitHub Comments

clemvighcommented, Dec 11, 2019

I think it may be because I ran CellBender on a server that only had python 3.6.8, and the example with the tiny pbmc dataset gave the same error as above. I tried to run it locally with python 3.7 and that worked fine.

sjflemingcommented, Aug 26, 2021

Hi @AlexanderAivazidis , from your log file, I cannot tell what has gone wrong unfortunately. I am guessing as you guessed that it may be a pytables issue… but I am not sure.

One thing to try would be to use the docker image, if you don’t want to debug the installation:

If you want to test out pytables, I would suggest, in python, trying

import tables
with tables.open_file('some_h5_file.h5') as f:

and make sure that will run

Read more comments on GitHub >

github_iconTop Results From Across the Web

F1013 Error writing output file (C++) - RAD Studio
A DOS error that prevents the C++ IDE from writing an .OBJ, .EXE, or temporary file. ... Make sure that the Output directory...
Read more >
Always 'error writing output file' in openssl
It's openssls incorrect handling of SIGPIPE . head and also dd will close the pipe when they have recieved their 5 MB.
Read more >
Unable to write to output file '<filename>': <error> - Visual Basic
In this article · The application is already running and using its files. To solve this problem, make sure that the application is...
Read more >
"XCOMN0416E Error writing output file: Invalid argument" for ...
It failed once for the first file transferred with: XCOMN0416E Error writing output file: Invalid argument. All subsequent files in the same ...
Read more >
DFC134 Error writing output file - Micro Focus
CONV was unable to successfully write the current record to the output file. Resolution: Ensure that the output file details are correct and...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found