Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

As year of 2020, suggest to upgrade kingly dependency from node version '6.3.0' only to compatible higher version.

See original GitHub issue

Thanks for this awesome lib. I was in trouble while I trying kingly.

❯❯❯ yarn add react-state-driven
error kingly@0.18.2: The engine "node" is incompatible with this module. Expected version "6.3.0". Got "12.8.0"
error Found incompatible module.

Can I suggest to upgrade node dependency version to some like "node": ">= 6.3.0" or else?

Thanks again.

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:22 (13 by maintainers)

github_iconTop GitHub Comments

brucoucommented, Jun 7, 2020

I rmoved the dependency on state-transducer-testing and graph-adt. can you try again with 0.10.8 of react-state-driven? you won’t be able to run tests, which is fine because tests are still depending on older versions of the library and I have to fix that this week-end.

brucoucommented, Jun 6, 2020

Just did it and update react-state-driven to 0.10.7. Can you please try again? hopefully this time it works. I will need to revisit all the build configuration over the week-end… sorry for the inconvenience.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Upgrading Node.js to latest version - Stack Overflow
If you just need to upgrade your old version of Node.js to the latest one and don't need multiple versions, simply over-write your...
Read more >
npm does not support Node.js v10.15.2 · Issue #1877 - GitHub
It looks like current installed npm is not compatible with Node.js version you are using. You'll probably need to update your npm using...
Read more >
How to Upgrade Dependencies in Your package.json
If you want to be a little conservative, the tilde dependency, “~15.2.0”, would suggest only a higher patch version would be used. Of...
Read more >
How to Easily Update Node.js to the Latest Version
There are several easy & quick ways of upgrading Node.js. Learn how to update ... Updating using a Node version manager on macOS...
Read more >
6.3.0 - npm
To install an old and unsupported version of npm that works on node v5 and prior, clone the git repo and dig through...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found