Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Version 7.0.2 still complains node_modules/angular-tree-component/dist/angular-tree-component.d.ts, found version 4, expected 3,

See original GitHub issue

ERROR in Error: Metadata version mismatch for module /Users/ning/www/x/node_modules/angular-tree-component/dist/angular-tree-component.d.ts, found version 4, expected 3, resolving symbol

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Reactions:8
  • Comments:9 (3 by maintainers)

github_iconTop GitHub Comments

mgpGit-zzcommented, Mar 20, 2018

@ningkexin I was able to get it to work by using the 7.0.2-beta1 version. see issue 578

Delete 3 folders under node_modules:

  • mobx
  • mobx-angular
  • angular-tree-component

Then install the beta1 version until the official release version is fixed:

  • npm install angular-tree-component@7.0.2-beta1

Now everything seems to be working…

TheoLechemiacommented, Sep 7, 2018

I have the same problem on version 8.0.0. Back to the 7.1.0 resolve it.

Read more comments on GitHub >

github_iconTop Results From Across the Web

angular - ERROR in Metadata version mismatch for module ...
The message seems clear : You need a version of angular core and common that is at least 5.0.0. Your package file show...
Read more >
Solved: ESXi 7.0.3 Upgrade Errors? - VMware Communities
Solved: I am attempting to upgrade a Dell R740xd cluster from 7.0.2 to 7.0.3. I have attempted multiple ways... Lifecycle Manager Baseline.
Read more >
VMware ESXi 7.0 Update 3 on Intel NUC -
They still work in ESXi 7.0 but VMware has announced that they will no longer be supported in future versions. As of today,...
Read more >
How to Upgrade from VMware vSphere ESXi 6.7 to 7.0
For example, upgrade first to version 6.5 and then to version 7.0. Otherwise, proceed with a clean installation of ESXi 7.0.
Read more >
VMware has recalled all released versions of vSphere 7.0 ...
VMware's vSphere ESXi 7.0 U3, U3a, and U3b and VMware vCenter 7.0 U3b are no longer available for download due to several critical...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found