Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Unable to remove a user from CLA.

See original GitHub issue

It seems there is no way at all to remove a user from the list of users covered by the CLA.

(Aside: There was a previous issue filed here #201, but that was closed due to it being “stale”, and then labeled as “wontfix”.)

We have a real world case of a user leaving a team, and now we need to update the list of users covered under the CLA to remove the username. Unfortunately, it doesn’t appear to be possible to do this.

I’ve tried exporting/import, but that doesn’t work.

URL to the linked Repo/Org:

Steps to reproduce the problem:

  1. Export list of users as csv file.
  2. Edit the file to remove the entry/line for a single user.
  3. Import the edited csv file.

What is the expected result? The user should be removed from the list of users.

What happens instead? The user is not removed.

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Reactions:3
  • Comments:7 (3 by maintainers)

github_iconTop GitHub Comments

jackkoenigcommented, Sep 14, 2020

In case anyone comes across this again. I tried this recently, and was able to successfully remove a user’s signature. Unfortunately, now they cannot sign again. Clicking I Agree just doesn’t seem to do anything.

I know next to nothing about web programming so please forgive any abuse of terminology, using Chrome DevTools the response upon clicking I Agree appears to be:

"Empty value for parameter 'owner': undefined"
MichaelTsengLZcommented, Jan 29, 2019

Try to hit this end-point with header like this:

x-token: 'your-personal-token'

with body like this:

// if you link an repo
  user: abc,
  userId: 123,
  endDate: '2019-01-29T01:53:31.779Z',
  owner: 'my-repo-org-name',
  repo: 'my-repo'
// if you link an org
  user: abc,
  userId: 123,
  endDate: '2019-01-29T01:53:31.779Z',
  org: 'my-org'

Here is the implementation details

Read more comments on GitHub >

github_iconTop Results From Across the Web

[SOLVED] cant delete user in AD - Spiceworks Community
If after that you still can't delete it, open ADSI and drill down to the user and beyond and delete each item below...
Read more >
Owner cannot remove members of a project if they ... - GitLab
When I want to remove someone from the repo, I don't see a button "remove from repository". It only happens to users that...
Read more >
Why am I unable to remove a user? | Geotab Knowledge Article
If you are unable to remove a user from your database, there could be a few reasons as to why this is not...
Read more >
Unable to remove user from group(or Confluence) with ...
Go to > General Configuration > Groups > Remove membership via Group Management; Go to > User Management > Delete user. The error...
Read more >
CSAC - Student Landing Home
It is important for you to understand that your WGS account does not replace your School or FAFSA accounts. Each account must be...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found