Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Raspberry Pi "Error opening serial port"

See original GitHub issue

I am not sure what’s wrong with my setup.

$ .npm/bin/cnc --host
Started the server at
2016-07-17T12:13:40.292Z - error: [cncserver] Error opening serial port "ttyAMA0": err={}     at /home/pi/.npm/lib/node_modules/cncjs/dist/cnc/app/index.js:1353:44

I can connect via minicom and cutecom, but not with cncjs =( Not sure what to try next.

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Comments:18

github_iconTop GitHub Comments

chetoncommented, Jul 20, 2016

Note that you may still need to add a ~/.cncrc file as I mentioned before in order to use /dev/ttyAMA0 instead of ttyAMA0.

chetoncommented, Jul 20, 2016

In general, you don’t need to manually specify the --config parameter unless the .cncrc file is not located at the login (home) directory.

I just updated the FAQ, it will help others if they encountered the similar problem.

Read more comments on GitHub >

github_iconTop Results From Across the Web

SOLVED: Serial port wont open. ERROR - Raspberry Pi Forums
Try this as a first go. ... Go to the enable serial port part. Say no to console and then yes to serial....
Read more >
Raspberry PI PICO - serial error - Arduino Forum
Hi, I have a problem with starting communication between the Raspberry Pi Pico and the Serial Monitor in Arduino 1.8.13.
Read more >
Raspberry Pi: Error opening serial port “ttyAMA0”; Webcam Streaming with Raspberry Pi; Restream RTSP to M-JPEG; Connect to an Arduino using WiFi ...
Read more >
Raspberry Pi UART Communication using Python and C
To provide portability in port name, serial aliases are created in Raspbian named as serial0 and serial1. serial0 referred to UART port mapped...
Read more >
[SOLVED]Raspberry Pi Zero 2 W cannot open the serial port
When I run the program, i get a error messages Waiting for debugger to connect... Program started. java.lang.UnsatisfiedLinkError: 'long...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found