Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Directline attachments don't work anymore

See original GitHub issue

Describe the bug Trying to upload an attachment using the latest version of the directline connector does not work anymore. The emulator will send an error back that path is not available in unknown. Downgrading to one older version will make it work again.

To Reproduce Use MEDIA with a directline convo and connect to a local bot through the botframework emulator.

Expected behavior Upload works and id for attachment is being returned.

Screenshots and Log files

Botium Flavour:

  • Botium Box -
  • Botium CLI -
  • Botium Bindings 2.0.18
  • DL 0.0.15

Botium Version 1.6.1

Additional context

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:11 (6 by maintainers)

github_iconTop GitHub Comments

alopixcommented, Oct 10, 2019

Oh, that is quite an interesting – quite an annoying issue with fetch. I tried he branch and it worked as expected. Thanks 👍🏼

codeforequity-atcommented, Oct 9, 2019

Now this is a nice one. What I found out:

  • It seems as if node-fetch 2.5.1 cannot handle the Content-Type header correctly, as compared to 2.3.3 (dependency was updated with 0.0.15). Didn’t dive into detail, but removing this header when uploading the attachment helped.
  • And with node-fetch 2.5.1 somehow the response handling changed, I had to rewrite two code lines - you are working with local file attachments, so this was not the problem in your case.
  • The Bot Framework Emulator requires an activity for the file upload - the Azure bot service does not. But both of them are fine with an empty activity, if no text is given in Botium.

The pull request is there, and it will be merged with the October release. Maybe you can check out the branch and test it:

Read more comments on GitHub >

github_iconTop Results From Across the Web

Unable to send Attachment in Webchat using directline, same ...
I was trying to send image as an item to click and save, i think i figured out the issue, directline supports only...
Read more >
Send file attachments between bot and agent from ...
In the case of sending attachments from Agent to User, I got an error in the Teams channel: "An exception occurred when converting...
Read more >
[DirectLine] Downloading received attachments randomly fails ...
[DirectLine] Downloading received attachments randomly fails with "File not found" error #255 ; Bot Services Required for internal Azure ...
Read more >
Extension and direct line for IP 7906 and 7911
Hi,. I have a CCM 4.1(3) and a Voive gw 2801 w E1 card (VWIC-1MFT-E1). How is it possible for phones 7906 &...
Read more >
Direct Line Missed Payment - Here's What To Do 2022
First, make sure your insurance payment didn't go through, which can happen when you do it online! Do this to confirm if the...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found