Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error running Fess 12.4.3 with 3 elastic 6.5.3 nodes cluster: failed to create index

See original GitHub issue

Hello, I’m trying to setup Fess on linux installed with the .deb package but I’m encountering problems.

I’m using Elasticsearch 6.5.3 and Fess 12.4.3

I’d like to use a 3-nodes external Elasticsearch cluster and let Fess use that. Is the scenario where Elasticsearch is installed on 3 different servers and Fess is installed on a 4th server in the same network supported? Or does fess need a local Elasticsearch node?

As I coulnd’t make Fess start in the previous setup I tried using a different scenario using docker to experiment: 3 Elasticsearch nodes on 3 different containers and a 4th container running Fess and Elasticsearch all belonging to the same cluster.

I tried with docker after trying with actual servers but encountered the same problems.

Fess is configured to talk to the Elasticsearch running on the same container.

On all the Elasticsearch nodes the plugins are installed, same version on each, and the configsync plugin is configured pointing to the same path on each node.

As long as the 3 elastic nodes are not running fess starts correctly and talks with the Elasticsearch node running on the same container. Problems arise when the other 3 nodes are started: they correctly join the cluster and sync the files in the configsync path but on each of the new nodes I receive the following error:

[2019-01-17T14:20:29,326][WARN ][o.e.i.c.IndicesClusterStateService] [node1] [[fess.20190117][2]] marking and sending shard failed due to [failed to create index] access denied ("" "/var/lib/elasticsearch/config/ja/mapping.txt" "read")
    at ~[?:?]
    at ~[?:?]
    at java.lang.SecurityManager.checkPermission( ~[?:?]
    at java.lang.SecurityManager.checkRead( ~[?:?]
    at ~[?:?]
    at sun.nio.fs.UnixChannelFactory.newFileChannel( ~[?:?]
    at sun.nio.fs.UnixChannelFactory.newFileChannel( ~[?:?]
    at sun.nio.fs.UnixFileSystemProvider.newByteChannel( ~[?:?]
    at java.nio.file.Files.newByteChannel( ~[?:?]
    at java.nio.file.Files.newByteChannel( ~[?:?]
    at java.nio.file.spi.FileSystemProvider.newInputStream( ~[?:?]
    at java.nio.file.Files.newInputStream( ~[?:?]
    at java.nio.file.Files.newBufferedReader( ~[?:?]
    at org.elasticsearch.index.analysis.Analysis.getWordList( ~[elasticsearch-6.5.3.jar:6.5.3]

However the file is readable and writable by elastic as elastic itself created it in that very folder.

This situation result in the cluster being in a yellow state because of unallocated shards.

Here you can find the docker-compose.yml file used

elastic-img is build with this Dockerfile

fess-img is build from the fess-docker repository, I changed to elastic non-oss release, used the 6.5.3 version instead of 6.5.4 and fixed the setting both in elasticsearch.yml and in a file, the latter is then copied to /opt/fess inside the container.

What am I doing wrong? Why do I get the access denied error? Are there any constrains on the elasticsearch node role? i.e. may all the nodes be master, ingestors and data nodes?

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:7 (3 by maintainers)

github_iconTop GitHub Comments

svalocommented, Jan 21, 2019

Maybe I misread the documentation but it may be useful to specify that the configsync path have to be the elasticseach config path.

Another thing I noticed is that the node local setting of the configsync path is not considered.

If I configure the es-fess node with configsync path set to /path/to/configsync/ and an elasticseach node with configsync path set to /a/different/path/to/configsync in the elasticsearch only node I will see in the logs that the files will be searched in /path/to/configsync/. Is this a known behaviour?

marevolcommented, Jan 21, 2019

Our official docker-compose.yml is here.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Fix common cluster issues | Elasticsearch Guide [8.5] | Elastic
A cluster in which nodes leave unexpectedly is unstable and can create several issues. « Troubleshooting Error: disk usage exceeded flood-stage watermark, index...
Read more >
Fix common cluster issues | Elasticsearch Guide [7.17] | Elastic
This guide describes how to fix common errors and problems with Elasticsearch clusters. Error: disk usage exceeded flood-stage watermark, index has ...
Read more >
Troubleshooting index lifecycle management errors - Elastic
This indicates that the cluster is running out of disk space. This can happen when you don't have index lifecycle management set up...
Read more >
Cluster fault detection | Elasticsearch Guide [8.5] | Elastic
By default, each health check times out after 10 seconds and Elasticsearch removes the node removed after three consecutively failed health checks.
Read more >
3 best practices for using and troubleshooting the Reindex API
We will review potential errors and give you best practice tips and ... from one index to another, or even from one Elasticsearch...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found