Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

RPM Dependency Error

See original GitHub issue

Issue Description

Change from http to https via the cli: config host_protocol https This creates the spinning stick. This process will never finish (i tried over 12h).

Reproduction Steps:

  1. Start the CLI
  2. config host_protocol https
  3. After a while, i press crt +c or close the putty connection, so nothing will work after that
  4. I checked puppet agent -t and a big error message appears:
  5. So i change it back to http and boom it works fine like before

Expected behavior:

https working

Observed behavior: rpm error (ref in puppet agent -t)

Codenvy version: 5.0.0-M5 OS and version: Red Hat Enterprise Linux Server release 7.2 (Maipo) Additional Info: Completely clean system, only installed codenvy via the script

Additional information:

Problem only started happening recently, didn’t happen in an older version of Codenvy: No Problem can be reliably reproduced: Yes

Diagnostic bundle Execute the script on this page and post public link to the bundle here. Can’t upload that file, non supported type of Github, so I uploaded that file here:

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Comments:17 (8 by maintainers)

github_iconTop GitHub Comments

TylerJewellcommented, Oct 15, 2016

Hi @maxibanki - sorry you are running into this issue. Can you take a look at the docs on this page - and follow the process proposed (it has you change some more items). Let us know if the issue still happens.

FWIW - we have a new packaging of Codenvy coming soon that will make the entire installation + configuration of Codenvy much simpler. Sorry you had this problem.

mxschmittcommented, Oct 21, 2016

@skryzhny thanks, but the vm of this installation is already deleted.

@dmytro-ndp thanks alot, with the startssl cert is it working almost fine. Just a big redirect error between: and

I tested it on other browsers which were resetted. Any suggestions?

Read more comments on GitHub >

github_iconTop Results From Across the Web

Solved "error: Failed dependencies:" Install/Remove rpm with ...
While installing or removing a rpm manually (without yum), you may get Failed dependencies error. It happens because a rpm requires certain pre- ......
Read more >
RPM installation error: failed dependencies - linux - Super User
rpm only knows about files that are installed by rpm packages. When you run: rpm -qf /usr/lib/
Read more >
How to make rpm auto install dependencies - Stack Overflow
The installation of proj1 fails due to a missing dependency. user@my-pc:~$ rpm -ivh proj1-1.0-1.x86_64.rpm error: Failed dependencies: libtest1.
Read more >
Why does rpm -i <package> fail on a dependency that I have ...
The error clearly states that libmicrohttpd needs a 64-bit library. Refer this link to get the required RPM. You can also configure yum...
Read more >
Tips for resolving unmet dependencies - IBM
Resolving RPM dependency failures​​ A Red Hat Enterprise Linux® client that is correctly configured to use the yum (Yellowdog Updater, Modified) package manager ......
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found