Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

ripemd160 is not supported

See original GitHub issue

Hi, when doing : var randomSeed = lightwallet.keystore.generateRandomSeed(extraEntropy)

it throw : Error: ripemd160 is not supported (we accept pull requests) Trace de la pile : module.exports@http://localhost:8080/app.js:151561:19 module.exports@http://localhost:8080/app.js:151550:11 Hash.ripemd160@http://localhost:8080/app.js:198294:11 Hash.sha256ripemd160@http://localhost:8080/app.js:198299:11 HDPrivateKey.prototype._buildFromBuffers@http://localhost:8080/app.js:207826:22 HDPrivateKey.prototype._buildFromObject@http://localhost:8080/app.js:207714:11 HDPrivateKey@http://localhost:8080/app.js:207469:6 HDPrivateKey.fromSeed@http://localhost:8080/app.js:207760:11 Mnemonic.prototype.toHDPrivateKey@http://localhost:8080/app.js:208956:11 KeyStore@http://localhost:8080/app.js:170272:19 newWallet/<@http://localhost:8080/app.js:143693:24 KeyStore.deriveKeyFromPassword/cb@http://localhost:8080/app.js:170628:8 scrypt/</<@http://localhost:8080/app.js:210140:10 scrypt/interruptedFor/<@http://localhost:8080/app.js:210099:12 onNextTick@http://localhost:8080/app.js:78599:10 drainQueue@http://localhost:8080/app.js:2310:18

As it is no (longer ?) supported, does anyone use it or everyone has forked eth-lightwallet to use another hash ?

Thank you

Issue Analytics

  • State:open
  • Created 7 years ago
  • Reactions:1
  • Comments:7 (1 by maintainers)

github_iconTop GitHub Comments

ericvrpcommented, Mar 1, 2017

I have encountered the same problem once I tried to use eth-lighwallet in a create-react-app . This is the solution I am using now.

// monkeypatch (see: import crypto from ‘crypto’ const sourceCreateHash = crypto.createHash crypto.createHash = function createHash(alg) { if (alg === ‘ripemd160’) { alg = ‘rmd160’ } return sourceCreateHash(alg) }

tmyjoecommented, Dec 23, 2016

I’ve encountered same error, but change to use webpack 2 instead of 1 solved my issue.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Unsupported hash type ripemd160 with hashlib in Python
Hashlib uses OpenSSL for ripemd160 and apparently OpenSSL disabled some older crypto algos around version 3.0 in November 2021.
Read more >
RIPEMD160 does not work · Issue #16994 · openssl ... - GitHub
The Bitcoin technical community considers RIPEMD160 inadequately secure and has been moving off of it since 2017. The most recent address type ...
Read more >
63857 (openssl3: ripemd160 not supported) - MacPorts Trac
I'm on Big Sur. Python 3.6, 3.7, 3.8, and 3.9 can't use the hashlib hasher "ripemd160", even though that hasher is listed as...
Read more >
1975836 – add ripemd160 hash back? (how to enable legacy ...
It was about removing plain mode use in OpenStack. Also cryptsetup will not move anything to unsupported, it will simply load legacy provider ......
Read more >
RIPEMD160_Init - OpenSSL
RIPEMD-160 is a cryptographic hash function with a 160 bit output. RIPEMD160() computes the RIPEMD-160 message digest of the n bytes at d...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found