ArtifactId should match module / repo name
See original GitHub issueRight now there’s microprofile-config
but the artifactId for the parent POM is defined as microprofile.config.parent
.
While dots as separators are quite common especially under Eclipse, see https://github.com/eclipse/rt.equinox.framework, the artifactId should match the module or repository name wherever possible.
So either microprofile.config.parent
in a repo microprofile.config
or an artifactId microprofile-config
in the existing name pattern.
Issue Analytics
- State:
- Created 7 years ago
- Comments:28 (27 by maintainers)
Top Results From Across the Web
Maven Tip: Project Directories Should Match the Artifact ID
Here's the rule: Name your project's directory after the artifactId of your project. It is much easier for everyone to quickly recognize and ......
Read more >Guide to Naming Conventions - Apache Maven
artifactId is the name of the jar without version. If you created it, then you can choose whatever name you want with lowercase...
Read more >Maven naming conventions for hierarchical multiple module ...
As you said: artifacId and module name should be the same. I would also recommend using the artifactId as name in the pom....
Read more >On JitPack's use of git repository name as Maven artifactId
Switching to a different artifactId on Maven Central to match the repository name would cause confusion, since older versions would have one ......
Read more >Naming rules for Maven modules and packages - jQAssistant
Each Java type must be located in a package that has a name starting with a prefix consisting of the groupId and artifactId...
Read more >Top Related Medium Post
No results found
Top Related StackOverflow Question
No results found
Troubleshoot Live Code
Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start FreeTop Related Reddit Thread
No results found
Top Related Hackernoon Post
No results found
Top Related Tweet
No results found
Top Related Dev.to Post
No results found
Top Related Hashnode Post
No results found
Top GitHub Comments
Why using underscores as separator? Hardly ever seeing that out there.
I’d use microprofile-config-1.0.0.Final.jar:
With my OSGi cap on, as for the bundle version, it has four parts major.minor.micro.qualifier. Since version can be compared, the major, minor and micro follow number comparison while qualifier can be strings, which will follow string comparison (alpha<beta<Final). When we say the number scheme of major.minor.micro.qualifier (microprofile-config-1.0.0.Final.jar), this is the final release. For an alpha release, we have microprofile-config-1.0.0.alpha.jar, which is smaller than microprofile-config-1.0.0.Final. At least, we can differentiate the different stages of the releases.