Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

The client noticed that the server is not a supported distribution of Elasticsearch (NEST 7.16 to Elasticsearch 7.9.0)

See original GitHub issue

NEST/Elasticsearch.Net version: 7.16.0

Elasticsearch version: 7.9.0

.NET runtime version: 4.7.2

Operating system version: Windows 10 / Server 2019

Description of the problem including expected versus actual behavior: I was previously using NEST/Elasticsearch.NET 7.9.0, but we are looking to upgrade to 7.16.2 for the LOG4J vurnability. Looking at your official documentation I noticed the following:

I have a 7.0 server, what client should I use?

Always use the latest minor version of the client within that major version, so in this instance, at time of writing, this is version 7.14.0. The reason being is that 7.14.x will contain many bug fixes not present in the 7.0.0 version of the client.

Client methods which call endpoints added to Elasticsearch since 7.0.0 will fail due to those endpoints not existing on the server.

So I upgraded my NEST/ElasticSearch to the latest minor version (7.16). Now when I try to connect to our Elastic Cluster I get the exception “The client noticed that the server is not a supported distribution of Elasticsearch”.

I would expect this to just work, according to your official documentation?

Steps to reproduce:

  1. Have ElasticSearch 7.9.0
  2. Have NEST/ElasticSearch 7.16.0
  3. Try to connect to ElasticSearch 7.9.0

Expected behavior I expected to be able to connect to the ElasticSearch cluster.

Provide ConnectionSettings (if relevant):

Provide DebugInformation (if relevant):

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:9 (5 by maintainers)

github_iconTop GitHub Comments

stevejgordoncommented, Jan 6, 2022

@Schoof-T You’re most welcome! I’ll close this issue for now since the client is behaving correctly. We can re-open if anything fails after the upgrade.

Schoof-Tcommented, Jan 6, 2022

Thanks for providing that information @Schoof-T. Unfortunately, this may be a bug in the MSI installer causing the build_flavor to be unknown and therefore causing the product check to fail. The MSI is considered beta and will no longer be produced after 7.16.2. In your case, I think you’ll need to first upgrade the nodes to the latest release of Elasticsearch using the zip package. Hopefully, that will resolve the unknown build_flavor that is reported. The 7.9.0 client should continue to be compatible with this newer server version. Once the server is upgraded and reporting a known build_flavor you can then update to the latest client. Note that I haven’t tested this myself and I’d advise testing your scenario in a non-production environment first to ensure that it works as expected.

I will test again after upgrading to 7.16.2 using the ZIP file. Thanks for the advice.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Node and elasticSearch client - The client noticed that ...
I tried upgrading @elastic/elasticsearch to latest version ^7.14.0 , but this did not resolve the issue. Nothing changed in AWS configuration ...
Read more >
NET Client Connection Issue - Elasticsearch
This is on a local network, and from within the same process, I have no problem connecting using the low-level client, using the...
Read more >
Breaking changes in 7.0 | Elasticsearch Guide [7.17]
An Elasticsearch 7.0 node will not start in the presence of indices created in a ... to collect secrets from the CLI at...
Read more >
[SOLVED] Error: The client noticed that the server is not a ...
I have setup the custom rules with the Elastic search plugins but ... "The client noticed that the server is not a supported...
Read more >
[Elasticsearch] The Server Is Not A Supported Distribution ...
UnsupportedProductError: The client noticed that the server is not a supported distribution of Elasticsearch. Error highlight:.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found