Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Personal config (~/.eslintrc) doesn't load global-installed configs/parsers/plugins

See original GitHub issue

Tell us about your environment

  • ESLint Version: 6.0.1
  • Node Version: 12.4.0
  • npm Version: 6.9.0

What parser (default, Babel-ESLint, etc.) are you using? default

Please show your full configuration:

  "env": {
    "browser": true,
    "commonjs": true,
    "es6": true,
    "node": true
  "extends": [
  "parserOptions": {
    "ecmaFeatures": {
      "jsx": true
    "sourceType": "module"
  "plugins": [
  "rules": {
    "no-const-assign": "warn",
    "no-this-before-super": "warn",
    "no-undef": "warn",
    "no-unreachable": "warn",
    "no-unused-vars": "warn",
    "constructor-super": "warn",
    "valid-typeof": "warn"

What did you do? Please include the actual source code causing the issue, as well as the command that you used to run ESLint.

I updated eslint from version 5.16.0 to 6.0.1 and, since I did it, eslint failes to start and I always receive this error: ‘Failed to load config “standard” to extend from eslint 6’.

What did you expect to happen?

I expected that all worked fine.

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Reactions:6
  • Comments:37 (13 by maintainers)

github_iconTop GitHub Comments

wintercountercommented, Oct 23, 2019

I had enough of this and created the following package:

It is a very unsafe and ugly workaround, it’ll patch your ESLint installation. For my use case it works fine for all our projects.

tonywoodecommented, Sep 23, 2019

my 2cents: I can’t upgrade eslint past v5, as ALE in Vim will report ‘Failed to load config “standard”’ - just as CLI does. I’ve read all issues here related to forcing users to stop using a global config, and I don’t agree for reasons already cited above in this ticket. I see no option open to me atm than to slowly die on v5? That does not seem reasonable

Read more comments on GitHub >

github_iconTop Results From Across the Web

Configuration Files - ESLint - Pluggable JavaScript Linter
A pluggable and configurable linter tool for identifying and reporting on patterns in JavaScript. Maintain your code quality with ease.
Read more >
Failed to load plugin 'import' declared in '... » eslint-config ...
I've tried setting it up through eslint --init, uninstalling eslint globally and having all the packages locally, installing each package ...
Read more >
failed to load config "standard" to extend from. -
I was attempting to set up a global configuration for ESLint, that way all my projects can follow a consistent code style, but...
Read more >
Local Install of ESLint Breaks In-Editor Linting
Currently this means requiring the team to install eslint, the current plugins and any future plugins globally, which is not ideal.
Read more >
eslint/eslint - Gitter
If ESLint is installed globally, then make sure eslint-plugin-prettier is also installed globally. A globally-installed ESLint cannot find a locally-installed ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found