Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Failed to compile - Failed to load config "react-app" to extend from

See original GitHub issue

Describe the bug

Create new react app with typescript template.
Following yarn start, no web page is loaded, error shows, Failed to load config "react-app" to extend from.

Did you try recovering your dependencies?


Which terms did you search for in User Guide?

“extend”, “failed”, “config”


npx create-react-app --info

Environment Info:

  current version of create-react-app: 4.0.1
  running from /Users/jjobbings/.nvm/versions/node/v12.20.1/lib/node_modules/create-react-app

    OS: macOS Mojave 10.14.6
    CPU: (8) x64 Intel(R) Core(TM) i7-4770HQ CPU @ 2.20GHz
    Node: 12.20.1 - ~/.nvm/versions/node/v12.20.1/bin/node
    Yarn: 2.4.0 - /usr/local/bin/yarn
    npm: 6.14.10 - ~/.nvm/versions/node/v12.20.1/bin/npm
    Chrome: 88.0.4324.96
    Edge: Not Found
    Firefox: 79.0
    Safari: 13.1.2
    react: Not Found
    react-dom: Not Found
    react-scripts: Not Found
    create-react-app: 4.0.1

Steps to reproduce

  1. yarn set version berry
  2. create-react-app onboard --template typescript
  3. cd onboard/
  4. yarn start

Expected behavior

React app start web page to display

Actual behavior

No ‘start’ web page successfully shown (browser displays error).

Failed to compile.

Failed to load config "react-app" to extend from.
Referenced from: /Users/jjobbings/onboard/package.json

browser opened - showing same error output as terminal.

Issue Analytics

  • State:open
  • Created 3 years ago
  • Reactions:54
  • Comments:13

github_iconTop GitHub Comments

guludocommented, Apr 5, 2021

For me the same error happened when I was migrating my project to use Yarn 2. I was using the following guide:

The command yarn start worked fine when not using the Plug’n’Play feature. The error started happening when I tried to enable the feature (by removing nodeLinker: "node-modules" from .yarnrc.yml). I’m inclined to believe that the issue is related to dependency issues, as the Plug’n’Play mode seems to be more strict with respect to how the module resolution works.

After checking and installing eslint-config-react-app (with yarn add eslint-config-react-app), the start script worked fine for me.

Note: I’m not using typescript, but I believe that is unrelated to the real issue.

fourpastmidnightcommented, Apr 23, 2021

@guludo Your response is spot on. I created a React app using yarn create react-app my-app --template typescript, followed the directions to migrate from yarn 1.22.x to 2.x and received the same error as everyone else. Then I used yarn add eslint-config-react-app from your comment, and immediately the stock skeleton application ran as expected. Good find. Thanks a lot. It took me most of a day to find this information and figure it out (not being a front-end developer myself 😉).

Read more comments on GitHub >

github_iconTop Results From Across the Web

Failed to load config "react" to extend from - Stack Overflow
I had a similar problem with create-react-app and I did yarn add eslint-config-react-app -D. I think you should try:
Read more >
Failed to load config "react-app" to extend from. #13283 - GitHub
Hey, after upgrade to v7.0.0 I see those build errors: Tell us about your environment ESLint Version: v7.0.0 Node Version: v13.14.0 npm ...
Read more >
[eslint] failed to load config "react-app" to extend from -
I am running across this issue when I run my React application: Failed to compile. eslint Failed to load config "react-app" to extend...
Read more >
If you get "Failed to load config "react-app" to extend from ...
In this post, we'll create a React project from scratch using create-react-app, add in the Apollo GraphQL client, and then use the SpaceX ......
Read more >
Failed to load config "react-app" to extend from. - Code Grepper
failed to load config "react-app" to extend from. Add Answer | View In TPC Matrix. Technical Problem Cluster First Answered On June 9,...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found