Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

yarn start throws error message after installing eslint-config-react-app

See original GitHub issue

Describe the bug

After running

npx create-react-app my-app

switching to my-app directory and running

yarn start

This works fine. Then I run the following on the command line (Please see for more information about this specific command here:

npx install-peerdeps --yarn --dev @upleveled/eslint-config-upleveled

and after that

yarn start

again. Still works fine. But as soon as I run

npx install-peerdeps --yarn --dev eslint-config-react-app

or as an alternative

npx install-peerdeps --yarn --dev --only-peers eslint-config-react-app

If I try

yarn start

now it gives me the following error message:

$ yarn start
yarn run v1.22.5
$ react-scripts start

There might be a problem with the project dependency tree.
It is likely not a bug in Create React App, but something you need to fix locally.

The react-scripts package provided by Create React App requires a dependency:

  "babel-eslint": "^10.1.0"

Don't try to install it manually: your package manager does it automatically.
However, a different version of babel-eslint was detected higher up in the tree:

  C:\Coding\workspace\my-custom-app-name\node_modules\babel-eslint (version: 10.0.0)

Manually installing incompatible versions is known to cause hard-to-debug issues.

If you would prefer to ignore this check, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That will permanently disable this message but you might encounter other issues.

To fix the dependency tree, try following the steps below in the exact order:

  1. Delete package-lock.json (not package.json!) and/or yarn.lock in your project folder.
  2. Delete node_modules in your project folder.
  3. Remove "babel-eslint" from dependencies and/or devDependencies in the package.json file in your project folder.
  4. Run npm install or yarn, depending on the package manager you use.

In most cases, this should be enough to fix the problem.
If this has not helped, there are a few other things you can try:

  5. If you used npm, install yarn ( and repeat the above steps with it instead.
     This may help because npm has known issues with package hoisting which may get resolved in future versions.

  6. Check if C:\Coding\workspace\my-custom-app-name\node_modules\babel-eslint is outside your project directory.
     For example, you might have accidentally installed something in your home folder.

  7. Try running npm ls babel-eslint in your project folder.
     This will tell you which other package (apart from the expected react-scripts) installed babel-eslint.

If nothing else helps, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That would permanently disable this preflight check in case you want to proceed anyway.

P.S. We know this message is long but please read the steps above :-) We hope you find them helpful!

error Command failed with exit code 1.
info Visit for documentation about this command.

User@User-PC MINGW64 /c/Coding/workspace/my-custom-app-name (main)

Did you try recovering your dependencies?

Yes, I did it with yarn as described.

(Write your answer here.)

Which terms did you search for in User Guide?

The react-scripts package provided by Create React App requires a dependency:

“babel-eslint”: “^10.1.0”

(Write your answer here if relevant.)


System: OS: Windows 10 10.0.19041 CPU: (8) x64 Intel® Core™ i7-2720QM CPU @ 2.20GHz Binaries: Node: 15.4.0 - C:\Program Files\nodejs\node.EXE Yarn: 1.22.5 - C:\Program Files (x86)\Yarn\bin\yarn.CMD npm: 7.1.1 - C:\Program Files\nodejs\npm.CMD Browsers: Chrome: 88.0.4324.104 Edge: Spartan (44.19041.423.0), Chromium (88.0.705.50) Internet Explorer: 11.0.19041.1 npmPackages: react: ^17.0.1 => 17.0.1 react-dom: ^17.0.1 => 17.0.1 react-scripts: 4.0.1 => 4.0.1 npmGlobalPackages: create-react-app: Not Found

Steps to reproduce

please see section ### Describe the bug

Expected behavior

yarn start 

Starts the react app.

Actual behavior

please see section ### Describe the bug

Reproducible demo

No changes in my project. Just created it as described in ### Describe the bug

Issue Analytics

  • State:open
  • Created 3 years ago
  • Reactions:5
  • Comments:7

github_iconTop GitHub Comments

palejo333commented, Mar 21, 2021

Hm, I just tried to create a reproducible demo at this repo with the following commands, and I could not reproduce this issue (my server starts with no issues):

mkdir reproduction
cd reproduction
npx create-react-app .
npx install-peerdeps --yarn --dev eslint-config-react-app
yarn start

@uebriges can you try this on your machine? Does this cause the same error you described above?

Wonder if it’s some resolution / Windows thing…? I’m on macOS.

I tried it on my Windows pc and it threw the error but not for my macOS laptop

karlhorkycommented, Apr 2, 2021

@apollo42 thanks! Maybe we can fix the issue over in nathanhleung/install-peerdeps#127 then.

@uebriges you can probably close this now.

Read more comments on GitHub >

github_iconTop Results From Across the Web

My create-react-app is failing to compile due to ESLint error
1. Delete package-lock.json (not package.json!) and/or yarn.lock in your project folder. · 2. Delete node_modules in your project folder. · 3.
Read more >
This package includes the shareable ESLint configuration used by Create React App. Please refer to its documentation: Getting Started – How to create...
Read more >
Getting Started with ESLint
A pluggable and configurable linter tool for identifying and reporting on patterns in JavaScript. Maintain your code quality with ease.
Read more >
error in [eslint] failed to load config "react-app" to extend from.
To solve your error message, you can simply remove the entry or replace it with a proper shared config (e.g. "eslint-config-airbnb" ). Make...
Read more >
How to Fix ERROR in Plugin 'react' was conflicted between ...
If you're seeing the error message "Plugin 'react' was conflicted between 'package.json' and 'eslint-config-react-app'" then it's likely ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found