Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

No output from running cells after installation on Windows

See original GitHub issue


I installed on Windows using the instructions in the README file. Everything appears fine, except running cells produces no output; e.g. if I open a new notebook, create a code cell with the code print(‘here’), and click the “run the selected cells and advance” button, the curser advances but no output is produced. Re-installing doesn’t fix this.


  1. Download .exe file from
  2. Install following setup prompts
  3. Open new notebook from the launcher
  4. Type any command that should produce output (e.g. a print statement)
  5. Click run cell

Expected behavior

Output should be produced but it isn’t. The curser moves to the next cell but no output is produced.


  • Operating System and version: Windows 10 pro
  • JupyterLab-Desktop version: Version 3.2.5-2
  • Installer: .exe
Troubleshoot Output
Paste the output from running `jupyter troubleshoot` from the terminal inside of JupyterLab-Desktop here.
Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.   

Try the new cross-platform PowerShell PS C:\Users\Lea> jupyter troubleshoot
jupyter : The term ‘jupyter’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again. At line:1 char:1

  • jupyter troubleshoot
  •   + CategoryInfo          : ObjectNotFound: (jupyter:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException

PS C:\Users\Lea> image

Hmm… the terminal doesn’t recognize this command.

You may want to sanitize the paths in the output.

Browser Output (required for interface issues after loading)
Paste the output from the DevTools JavaScript console here, if applicable.


Logs (required for issues with loading, server and startup)
Paste the logs from the mian.log file here.

C:\Users<username>\AppData\Roaming\jupyterlab-desktop\logs exists as a path, but main.log is not there.

Issue Analytics

  • State:open
  • Created 2 years ago
  • Comments:12 (3 by maintainers)

github_iconTop GitHub Comments

astroStudent123commented, Jan 6, 2022

Thanks! the main.log file is still not there though.

On Thu, Jan 6, 2022 at 10:32 AM Michał Krassowski @.***> wrote:

The console tab is here:

[image: console-circle]

I cannot access this file. The %USERPROFILE%\AppData\Roaming\jupyterlab-desktop\logs\main.log filepath does not exist.

Could you try to look once again in similar paths? It might be in a slightly different path:

  • because of differences between Windows versions
  • because of differences between installations
  • because there is a typo

%USERPROFILE% may correspond to C:\Users\yourusername - Windows should recognise this variable when you use it in command line.

— Reply to this email directly, view it on GitHub, or unsubscribe . Triage notifications on the go with GitHub Mobile for iOS or Android

You are receiving this because you authored the thread.Message ID: @.***>

astroStudent123commented, Jan 17, 2022

Hi, Actually, it looks like while that solution worked the first time, when I try to launch JupyterLab the same way again it doesn’t work. The first time (a few days ago) that I ran:


jlab .

It opened successfully. But now when I run the activate command, I get: [image: image.png]

If I try just running the jlab command without the activate command first, a dialog box pops up asking me to select the Python environment to use, but when I select “Use the bundled Python environment”, click “save and restart,” the dialog box simply pops up again in an endless cycle. I could try "Use custom Python environment, but I am not sure how to do that. [image: image.png] Virus-free. <#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>

On Thu, Jan 13, 2022 at 11:29 AM Zuckerman, Leah < @.***> wrote:

Hi, That worked. Thanks so much!

On Thu, Jan 13, 2022 at 4:36 AM aravindh-krishnamoorthy < @.***> wrote:

@PhilipTsv @astroStudent123 Check if the workaround in #388 helps you. In my case, double clicking on the desktop shortcut resulted in no outputs from the cells. But, activating conda and then starting jlab as in #388 worked.

— Reply to this email directly, view it on GitHub, or unsubscribe . Triage notifications on the go with GitHub Mobile for iOS or Android

You are receiving this because you were mentioned.Message ID: @.***>

Read more comments on GitHub >

github_iconTop Results From Across the Web

windows 7 x64 - IPython notebook does not produce output
When I run IPython Notebook, it presents the landing pages and open new or imported notebooks, but it does not produce any output...
Read more >
PyCharm - Run and debug Jupyter notebook code cells
Use the following smart shortcuts to quickly run the code cells: Ctrl+Enter : Runs the current cell. Shift+Enter : Runs the current cell...
Read more >
What to do when things go wrong - The Jupyter Notebook
If Jupyter gives an error that it can't find notebook , check with pip or conda that the notebook package is installed. Try...
Read more >
Essential notebook commands - ArcGIS Enterprise
However, this cell type is no longer used in Jupyter notebook environments. ... If you run a cell containing only that variable name,...
Read more >
Troubleshooting Guide · Hydrogen - nteract
No kernel for grammar Python found error on Mac OS. First off, make sure that you run python3 -m pip install ipykernel python3...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found