Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

installation hangs at resolving packages phase

See original GitHub issue

Console output:

jupyter labextension install --debug  @jupyterlab/google-drive                                                                                         
> /Users/adivish/miniconda3/envs/aqua/bin/npm pack @jupyterlab/google-drive
> node /Users/adivish/miniconda3/envs/aqua/lib/python3.6/site-packages/jupyterlab/staging/yarn.js install
yarn install v1.5.1
(node:8861) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
info No lockfile found.
[1/4] 🔍  Resolving packages...
⠁ @jupyterlab/google-drive@file:../extensions/jupyterlab-google-drive-0.12.0.tgz

The installation hangs on the last line. Any ideas?

Issue Analytics

  • State:open
  • Created 5 years ago
  • Reactions:8
  • Comments:6 (3 by maintainers)

github_iconTop GitHub Comments

marcuscmycommented, May 28, 2018

Hi I am having the same issue, I have tried to build the extension using developer mode by downloading the git directory manually and I bumped into the same issue.

My npm version is 5.6.0

ManuFigueroacommented, Dec 18, 2018

@ian-r-rose Hey sorry I didn’t check this until today, node is v10.4.1 and npm is 6.1.0

EDIT: Tried with node v9.11.1 and npm v5.6.0 cause that worked for a co-worker but I had the same issue.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Stuck on "Resolving Packages" - Unity Forum
[Package Manager] Failed to resolve packages: Cannot connect to Unity Package Manager local server. No packages loaded.
Read more >
yarn install --har hangs at "Resolving Packages" #536 - GitHub
When running yarn install --har (with lock file present) the install gets stuck on Resolving packages: $ yarn install --har yarn ...
Read more >
Unity stuck at resolving packages after upgrading to 9.8.5
Hi everyone, My Unity project is stuck at "Resolving Packages" step and the project won't open after upgrading my Vuforia package to 9.8.5....
Read more >
Unity Package manager stuck on resolving packages
Use the Unity Package Manager (in Unity's top menu: Window > Package Manager) to view which packages are available for installation or already...
Read more >
Stuck on resolving packages in 2020.3 LTS? Try this! : r/Unity3D
Apparently all you have to do is disabling "Install toolchain package automatically" in the project settings.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found