Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Action failing on macOS 10.15

See original GitHub issue

Hello, I tried to use install-qt-action to get qt on macOS 10.15 runner. The step is failing:

brew install p7zip
Warning: p7zip 16.02_2 is already installed and up-to-date
To reinstall 16.02_2, run `brew reinstall p7zip`
python3 -m pip install setuptools wheel
Requirement already satisfied: setuptools in /usr/local/lib/python3.9/site-packages (50.3.2)
Requirement already satisfied: wheel in /usr/local/lib/python3.9/site-packages (0.35.1)
python3 -m pip install py7zr==0.10.1
Collecting py7zr==0.10.1
  Downloading py7zr-0.10.1-py3-none-any.whl (62 kB)
Collecting pycryptodome
  Downloading pycryptodome-3.9.9.tar.gz (15.5 MB)
Collecting texttable
  Downloading texttable-1.6.3-py2.py3-none-any.whl (10 kB)
Building wheels for collected packages: pycryptodome
  Building wheel for pycryptodome ( started
  Building wheel for pycryptodome ( finished with status 'error'
  ERROR: Command errored out with exit status 1:
   command: /usr/local/opt/python@3.9/bin/python3.9 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/24/8k48jl6d249_n_qfxwsl6xvm0000gn/T/pip-install-7ia01e4_/pycryptodome/'"'"'; __file__='"'"'/private/var/folders/24/8k48jl6d249_n_qfxwsl6xvm0000gn/T/pip-install-7ia01e4_/pycryptodome/'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d /private/var/folders/24/8k48jl6d249_n_qfxwsl6xvm0000gn/T/pip-wheel-u1yfcjec
       cwd: /private/var/folders/24/8k48jl6d249_n_qfxwsl6xvm0000gn/T/pip-install-7ia01e4_/pycryptodome/

EDIT: I submitted an issue with pycryptodome as well

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:15 (7 by maintainers)

github_iconTop GitHub Comments

zraxcommented, Dec 9, 2020

For anyone else running into this on GitHub’s official macOS runners, it turns out that setting MACOSX_DEPLOYMENT_TARGET in your environment will also break it in the same way. I just moved this down to my actual build step, and everything works fine again.

dyfercommented, Nov 28, 2021

This seems to have been fixed for quite some time (i.e. the action worked even if DEVELOPER_DIR was set), but a few weeks ago it started failing again. The DEVELOPER_DIR: '' solution still works though.

Read more comments on GitHub >

github_iconTop Results From Across the Web

GitHub Actions The macOS 10.15 Actions runner image is ...
The macOS 10.15 Actions runner image started our deprecation process on 5/31/22 and will be fully unsupported by 8/30/22. To raise awareness of ......
Read more >
The macOS 10.15 Actions runner image will begin ... - GitHub
The macOS 10.15 Actions runner image will begin deprecation on 5/31/22 and will be fully unsupported by 12/1/22 for GitHub and ADO #5583....
Read more >
Common MacOS Catalina Problems and How to Fix Them
Here's how to fix common problems with MacOS Catalina. ... Use the Finder menu to search for the Install MacOS 10.15 file and...
Read more >
8 Common macOS Catalina Problems and Solutions
Read this guide to know about 8 common macOS Catalina problems along with their easy solutions. Safe and useful tips by macOS expert....
Read more >
Codesign fails only in GitHubActions, Succeed in MacOS ...
I'm trying to setup a GitHub actions workflow to perform build on MacOS(10.15.7) system using self-hosted runner. My action workflow for ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found