Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

No module named aqt on OSX worker

See original GitHub issue

Recently (just few hours ago) OSX jobs e.g. started to fail with:

pip3 install aqtinstall==0.9.4
Collecting aqtinstall==0.9.4
  Downloading aqtinstall-0.9.4-py2.py3-none-any.whl (27 kB)
Collecting requests
  Downloading requests-2.24.0-py2.py3-none-any.whl (61 kB)
Collecting packaging
  Downloading packaging-20.4-py2.py3-none-any.whl (37 kB)
Requirement already satisfied: wheel in /usr/local/lib/python3.9/site-packages (from aqtinstall==0.9.4) (0.35.1)
Requirement already satisfied: py7zr>=0.9.1 in /usr/local/lib/python3.9/site-packages (from aqtinstall==0.9.4) (0.9.1)
Collecting urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1
  Downloading urllib3-1.25.10-py2.py3-none-any.whl (127 kB)
Collecting chardet<4,>=3.0.2
  Downloading chardet-3.0.4-py2.py3-none-any.whl (133 kB)
Collecting idna<3,>=2.5
  Downloading idna-2.10-py2.py3-none-any.whl (58 kB)
Collecting certifi>=2017.4.17
  Downloading certifi-2020.6.20-py2.py3-none-any.whl (156 kB)
Collecting six
  Downloading six-1.15.0-py2.py3-none-any.whl (10 kB)
Collecting pyparsing>=2.0.2
  Downloading pyparsing-2.4.7-py2.py3-none-any.whl (67 kB)
Requirement already satisfied: pycryptodome in /usr/local/lib/python3.9/site-packages (from py7zr>=0.9.1->aqtinstall==0.9.4) (3.9.8)
Requirement already satisfied: texttable in /usr/local/lib/python3.9/site-packages (from py7zr>=0.9.1->aqtinstall==0.9.4) (1.6.3)
Installing collected packages: urllib3, chardet, idna, certifi, requests, six, pyparsing, packaging, aqtinstall
Successfully installed aqtinstall-0.9.4 certifi-2020.6.20 chardet-3.0.4 idna-2.10 packaging-20.4 pyparsing-2.4.7 requests-2.24.0 six-1.15.0 urllib3-1.25.10
python3 -m aqt install -O /Users/runner/work/atomicDEX-Desktop/atomicDEX-Desktop/Qt 5.15.0 mac desktop -m qtcharts qtwidgets debug_info
/usr/local/opt/python@3.8/bin/python3.8: No module named aqt
Error: The process 'python3' failed with exit code 1

a little bit confused rn, probably there were some changes in worker image (package installing for python3.9 but python3 aliased for python3.8)

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Reactions:2
  • Comments:6 (4 by maintainers)

github_iconTop GitHub Comments

jurplelcommented, Oct 15, 2020 I reported the issue and they fixed the problem on their side.

tonymoronycommented, Oct 15, 2020

Apparently it started to work correctly today for us. I wonder GH reverted some changes in their virutal-environment.

Closing this issue for now. Anyway it’s not this particual action related.

Read more comments on GitHub >

github_iconTop Results From Across the Web

No module named aqt - Development - Anki Forums - AnkiWeb
I am trying the basic addon described here: it says ModuleNotFoundError: No module named ...
Read more >
aqtinstall/ at master - GitHub
# No desktop Qt is installed, but the user has requested installation. Find out what to install.
Read more >
ImportError: No module named bs4 on mac - Stack Overflow
The solution is in setting up the PATH the packages get installed. EPD or Canopy create their VirtualEnv set up in the .\~profile...
Read more >
ModuleNotFoundError: No module named 'aqt' - RoseIndia.Net
Hi, My Python program is throwing following error: ModuleNotFoundError: No module named 'aqt' How to remove the ModuleNotFound.
Read more >
Solved: Mac Set Name Script fails on Monterey 12.3
Solved: Greetings all, I have a script (I did not create this) to allow techs ... line 1, in <module> ModuleNotFoundError: No module...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found