Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

BeamNG.research Connection problem

See original GitHub issue

I just downloaded (via SVN) the BeamNG.research repository. is empty. In a conda enviroment I installed BeamNGpy via pip install beamngpy.

When I try the example code with west_coast_usa, BeamNG starts but after a short time it threws the following error:

055.319|D|GELua.scenario_scenarios.scenarios|should run: false; state: running 055.322|E|GELua.core_levels.levels|info.json missing: /levels/garage/info.json 055.325|E|GELua.core_levels.levels|No entry point for level found: /levels/garage. Ignoring level. 055.442|E|GELua.ResearchCom|Error reading from socket: closed 055.472|E|GELua.core_levels.levels|info.json missing: /levels/garage/info.json 055.473|E|GELua.core_levels.levels|No entry point for level found: /levels/garage. Ignoring level. 055.613|E|libbeamng.lua.V.ResearchCom|Error reading from socket: closed 057.143|I|libbeamng.lua.V.ResearchVE|Trying to connect to: localhost:64257 059.355|I|libbeamng.lua.V.ResearchVE|Could not connect... 060.001|I|GELua.util_researchGE.ResearchGE|Trying to connect to: localhost:64256 062.317|I|GELua.util_researchGE.ResearchGE|Could not connect... 063.386|I|libbeamng.lua.V.ResearchVE|Trying to connect to: localhost:64257 065.533|I|libbeamng.lua.V.ResearchVE|Could not connect... 065.735|I|GELua.util_researchGE.ResearchGE|Trying to connect to: localhost:64256 067.760|I|GELua.util_researchGE.ResearchGE|Could not connect... 074.911|I|GELua.util_researchGE.ResearchGE|Trying to connect to: localhost:64256

What could be the problem?

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:8 (1 by maintainers)

github_iconTop GitHub Comments

vladimirwestcommented, Oct 24, 2019

The game is running perfectly when python script is executing. So simplest solution that worked for me is add time.sleep(99999) to the end of the main python script.

manojhuilgolcommented, Nov 15, 2019

@vladimirwest Can you please describe where exactly did you add time.sleep() ? I tried adding it inside def main() function, but still it is not working.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Status heap corruption | BeamNG
I have had frequent crashes lately. Just recently I did cleared cache and removed mods, but when I tab trough several vehicles, like...
Read more >
Support -
If you still cannot find any solution for your issue, contact us on
Read more > - How to Fix Server/Connection Issues - YouTube
beamng drive connection error please rejoin the server, beamng drive connection error please join the server, beamng drive connection error ...
Read more >
BeamNG: VStates not queued - Stack Overflow
EDIT: I realized that the error occurrs in the a lua file of BeamNG.research. More precisely <beamNG_basedir>/lua/ge/extensions/util/ ...
Read more >
TR-Precrime-2020-01 Vincenzo Riccio, Paolo Tonella
consequence, the problem of testing Deep Learning (DL) systems to ensure their ... The BeamNG case study is a self-driving car equipped with...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found